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Document accessibility: What it is and why it matters 
Accessible design means deliberately considering the needs of individuals with 

disabilities throughout the design process, resulting in experiences that make 

everyone feel welcome, regardless of their abilities or access methods. 

Who benefits from accessible communication? 
Title 36 of the US Code of Federal Regulations says that agencies must ensure 

that all functionality of ICT is accessible to and usable by individuals with 

disabilities, either directly or by supporting the use of assistive technology. For 

functions not otherwise covered, the ICT function should be accessible to those 

with any of the following functional limitations: 

• People without vision or with limited vision 

• People without perception of color 

https://www.ecfr.gov/current/title-36/appendix-Appendix%20C%20to%20Part%201194#p-Appendix-C-to-Part-1194(302)


• People without hearing or with limited hearing 

• People without speech 

• People with limited manipulation, reach or strength 

• People with limited language, cognitive, and learning abilities 

Assistive technology examples 
• Screen reader 

• Screen magnifier 

• Text reader 

• Speech input 

• Alternative keyboard 

• Refreshable braille display 

POUR principles of accessibility 
The Web Accessibility Initiative, part of the international World Wide Web 

Consortium, has identified 4 guiding principles crucial to accessible content. The 

POUR principles define accessible content as: 

  Perceivable - Content can be perceived through various senses.  

  Operable - Interactions work regardless of how users interact with them.  

  Understandable - Content is clear, predictable, and consistent.  

  Robust - Content follows best practices to ensure compatibility with different 

devices, browsers, and assistive technologies (AT). 

Regulations and standards 
• Rehabilitation Act of 1973 

o Section 504 prohibits discrimination based on disability in any program, 

service or activity that either receives Federal financial assistance or is 

conducted by a Federal agency. 

o Section 508 requires Federal agencies to make all information and 

communications technology (ICT) accessible to employees and members 

of the public with disabilities. 

• Americans with Disabilities Act: A civil rights law that prevents employers, 

state and local governments, places of public accommodation, and 

telecommunications providers from discriminating against people with 

disabilities. 

https://www.w3.org/WAI/fundamentals/accessibility-principles/
https://www.access-board.gov/about/law/ra.html
https://www.hhs.gov/civil-rights/for-individuals/disability/section-504-rehabilitation-act-of-1973/part-84-final-rule-fact-sheet/index.html
https://www.access-board.gov/about/law/ra.html#section-508-federal-electronic-and-information-technology
https://www.ada.gov/


• Web Content Accessibility Guidelines (WCAG): Technical standards developed 

by the World Wide Web Consortium that can be used to test accessibility of 

digital content. The Section 508 and ADA accessibility requirements 

incorporate the WCAG standards by reference. 

Screen readers 
A screen reader is a piece of software that helps someone without vision or with 

limited vision interact with computers and other digital technologies. In the United 

States alone, more than 7 million people have some form of visual disability. Some 

common screen readers include: 

• NVDA (NonVisual Desktop Access) 

• JAWS (Job Access With Speech) 

• VoiceOver 

• Windows Narrator 

• TalkBack 

• Orca 

Accessible file formats 

Office XML (.docx, .pptx) 

Advantages 

• Easy to create and edit 

• Simple formatting 

• Lots of free templates 

• Built-in accessibility tools 

• Integrate with other Office 

products 

Disadvantages 

• Require paid programs to create 

and edit 

• Formatting limitations 

• Extremely limited form capability 

• No support for complex tables 

• Only Edge allows viewing without 

a plugin 

PDF (Portable Document Format) 

Advantages 

• Native viewing in all major 

browsers 

• Accessibility tag tree for maximum 

UX control 

• Preserves advanced layouts and 

‘floating’ content 

Disadvantages 

• Creating requires expensive 

software (Adobe Acrobat) 

• Much more difficult to change 

and edit document content 

• Requires a bit more tech-savvy to 

fix things 

https://www.w3.org/TR/WCAG22/
https://www.nvaccess.org/download/
https://www.freedomscientific.com/products/software/jaws/
https://support.apple.com/guide/iphone/turn-on-and-practice-voiceover-iph3e2e415f/ios
https://support.microsoft.com/en-us/windows/complete-guide-to-narrator-e4397a0d-ef4f-b386-d8ae-c172f109bdb1
https://support.google.com/accessibility/android/answer/6283677?hl=en
https://orca.gnome.org/


PDF/UA Standard 

The PDF/UA (Universal Access) standard was introduced in 2012. PDF/UA 

documents are the standard for sharing information while preserving the 

document layout and design. A PDF meets the PDF/UA standard if: 

• All meaningful content is tagged 

• Tags are semantically appropriate 

• Tag tree reflects logical reading order 

HTML and web content 
Advantages 

• Users have more control over 

display 

• Easy to share 

• Modern CMSs make authoring 

simpler 

• Search engine indexing 

Disadvantages 

• Print formatting is harder to 

control 

• Raw HTML is intimidating 

• Limitations of platform (such as 

the current WordPress or Drupal 

theme) 

Images and contrast 

Alternative text (alt text) 
• Read by a screen reader 

• Indexed by search engines 

• Displayed if an image fails to load 

• Context is key  

Color contrast 
• Difference in brightness between foreground and background colors or 

elements 

• Pertains to images, text, and icons 

• Color contrast is commonly represented as a ratio between 1:1 and 21:1– the 

higher the first number, the greater the contrast 

• WCAG 2.0 Level AA requires a contrast ratio of at least 4.5:1 between text and 

background 



Don’t rely on color alone to communicate or organize information 
Less accessible More accessible 

Fonts and typography 
• Font sizes are highly dependent on media type 

o Footnote text: 9pt 

o Body text: 12pt - 14pt 

o Headings: 18pt – 24pt 

• Text left-aligned or justified 

• Limit the use of italics 

Choosing a font family 
Font choices are subjective. Choose what you think looks best but ask for 

feedback from clients or colleagues. 

• Sans-serif fonts like Roboto or Arial are easier to read as body text, especially 

with longer digital documents. 
• Serif fonts like Times New Roman or Playfair Display stand out as headings and 

are good for longer printed documents. 

• Overly decorative fonts like Yellowtail or Rubik Glitch can be used sparingly for 

logos or special text but shouldn’t contain essential information. 

Text formatting 
• Lists are tagged appropriately 

• Columns use column formatting instead of tabs 

• Link names are unique and descriptive 

• Proofing language is set and matches majority content 

o Content in other languages is tagged appropriately 



Headings 
Use headings in your documents, slides, and web content to help users navigate 

the document more easily. 

• Provide structure, not style 

• Nested hierarchically 

• Label sections of the page 

• Describe the content or purpose of a section 

Office 365 accessibility 
Note: Content located in headers or footers in Office documents is not accessible 

to assistive technologies. Avoid putting important information, such as text 

identifying a document as ‘Confidential’, in these locations. If the information is 

vital, be sure to include it in the body of the document as well. 

Document identification 
• File name is descriptive and identifies the document or its purpose 

• Presentation or document title is set 

o File > Info > Properties > Title 

• Files are saved in the most current format (.docx or .pptx) 

Office accessibility tools 
Check Accessibility 

• Click Accessibility: Investigate in the Status bar OR 

• Click Review > Check Accessibility in the ribbon 

Alt Text 

• Right click an image and select View Alt Text OR 

• Select the image and navigate to Picture format > Alt Text in the ribbon 

• Check the Mark as decorative checkbox for decorative images 

Working smarter 

• Make edits to the source document instead of the PDF 

• Save well-formatted files as templates so you don’t have to work so hard 

the next time 



Microsoft Word tips 
Paragraph & heading styles 

• Use the Styles pane to designate headings and apply reusable formatting 

• Built-in headings styles automatically update document structure 

• Use line and paragraph spacing instead of new lines to add whitespace 

Layout options and text wrapping 

• Images, shapes and text boxes should be in-line when sharing source files 

• Must include alternative text or be described in the surrounding content 

• Elements with text wrapping are accessible when exporting to PDF 

Microsoft PowerPoint tips 
Embedding multimedia 

• Audio, video, and multimedia files include captions or other alternatives 

o Captions are reviewed for accuracy and completeness 

• The presentation does not contain flashing objects 

Reading order pane 

• Navigate to Review > Check Accessibility > Reading Order Pane in the 

ribbon 

• Should match the visual order to the greatest extent possible 

• Clearing checkboxes marks items as decorative and hides them from 

assistive technologies 

Reviewing a PDF in Adobe Acrobat 
Adobe Acrobat Pro is the gold standard in software for editing PDF files. Creating 

a PDF from scratch in Acrobat is time consuming and frustrating for even the 

most tech-savvy creators. Because Adobe open-sourced the PDF format in 2008, 

however, more user-friendly applications like Word and PowerPoint can export 

directly to PDF. Following the tips in the sections above should result in an 

accessible PDF export, but we can use Acrobat Pro to check PDFs and make 

small changes as needed. 



Document properties 
Access the Document properties panel by selecting Menu > Document 
properties or using the keyboard shortcut Ctrl + D. 

Description tab 

• The document must include a descriptive Title that identifies the current 

document without requiring users to read or interpret page content. 

• Advanced > Tagged PDF should be marked Yes. 

Security tab 

• Regardless of the Security Method, Content Copying for Accessibility must 
be Allowed 

Initial View tab 

• Make sure Window Options > Show is set to Document Title rather than File 
Name. 

Advanced tab 

• Ensure that a Language is selected in the Reading Options group  

• The language should match the primary language of the PDF. 

Reading order 
Side panel 

• Fix the order in which objects are read by Adobe and by Adobe’s Read out loud 

feature 

• Solve basic tagging issues in a PDF 

Floating panel 

• Used for manually tagging a PDF 

o Choose between displaying page content order and structure type for the 

elements on the page 

o Group like elements, such as multiple paragraphs, into a single block 

• Includes the Table Editor for creating tables with proper markup 

o Mark cells as header cells (<th>) or data cells (<td>) 

o Set the scope of header cells 

o Manage complex tables by allowing headers to span rows or columns 



o Manually select header cells if Adobe gets them wrong 

Accessibility tags panel 
• View and edit the tag tree 

• Affects the order in which assistive technology reads the document 

• Should be a last resort for fixing (but an important step in checking) a PDF 

• Right click a tag and select Properties to open the Object properties pane 

o Select the tag Type from the dropdown 

o The tag’s Title only labels the tag in the tags panel and does not affect the 

way it is read by assistive technology 

o Setting the Actual Text field will override what a screen reader finds in the 

document. Any text contained in the tag will not be read. 

o The Alternate Text for Images and Alternate Text for Links fields allow 

you to add meaningful descriptions to elements. Alternate text should be 

added to the <Link> or <Figure> tag rather than any of the contents. 

Resources 

• Course resources website 

• NVDA for Windows Keyboard Commands: Quick reference guide  

• WCAG Quick Reference – A helpful, customizable quick reference to WCAG 

2.0 requirements and techniques 

• Understanding WCAG 2.0 - A less technical guide to understanding and 

implementing WCAG 2.0 

Color contrast testing 
• WebAIM: Contrast Checker 

• Color contrast checker analyzer tool | Adobe Color 

• Color Contrast Analyzer (CCA) 

o CCA 2.5 for Windows 

o CCA 2.4 for macOS 

• Color Blind Vision Simulator | Color Blind Glasses Simulator (pilestone.com) 

https://technicalassistance.hdiuky.net/accessible-document-links/
https://dequeuniversity.com/screenreaders/nvda-keyboard-shortcuts
http://www.w3.org/WAI/WCAG21/quickref/?versions=2.0
https://www.w3.org/TR/UNDERSTANDING-WCAG20/
https://color.adobe.com/create/color-contrast-analyzer
https://www.paciellogroup.com/resources/contrastanalyser/
https://github.com/ThePacielloGroup/CCA-Win/releases/tag/2.5.0
https://github.com/ThePacielloGroup/CCA-OSX/releases/tag/2.4
https://pilestone.com/pages/color-blindness-simulator-1


Other testing tools 
• ANDI (Accessible Name & Description Inspector) is a free web accessibility 

testing tool maintained by the US Social Security Administration. 

• NVDA (NonVisual Desktop Access) – Free screen reader software for 

Windows computers 

• PDF Accessibility Checker (PAC) 2021 – PDF/UA Foundation – Free tool for 
analyzing PDF accessibility. Indicates errors but doesn’t fix them. 

https://www.ssa.gov/accessibility/andi/help/install.html
https://www.nvaccess.org/download/
https://pdfua.foundation/en/pdf-accessibility-checker-pac/
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